[packman] Packaging request - VidCutter

Carlos E. R. robin.listas at telefonica.net
Tue Feb 14 21:55:03 CET 2017

Hash: SHA256

El 2017-02-14 a las 19:51 -0000, Gerhard Kühbauer escribió:

> Hello everybody and first of all let me say a big, big thank you to the
> Packman-Team and especially Luigi Baldoni for adding Vidcutter so
> quickly to the packman-repo and making it easily available for all the
> openSUSE/SUSE-users out there. Thanks a lot for all your efforts and let
> me assure you that they are really appreciated!

Absolutely :-)

> Am 2017-02-14 um 19:16 schrieb Carlos E. R.:
>> However, it does not work well here.
>> If on the terminal I do "vidcutter video.mpeg" it crashes...
>> The same movie opens from the menu, but the display of the movie is
>> grey. If I move the slider I see grey shapes on the display, but the
>> slider itself is empty. If I hit "play" it does play. If I move the
>> slider with the keyboard, most frams desplay grey content with some
>> weird shapes, and now and then a frame from the movie.
>> This way I can not seek the sections to cut...
> I'm afraid I'm really not much help here, but I can at least confirm
> that starting Vidcutter from a terminal with vidcutter mymovie causes
> the program to crash. If you provide the full path - for example:
> vidcutter /media/VIDEO/mymovie then vidcutter starts and opens the video
> correctly. Tried that half a dozen times with various videofiles in the
> last minutes, it always worked. Strange, but maybe it is an acceptable
> workaround for you till the issue is fixed.

Yes, it is a minor issue and I suppose an easy one to correct.

> I've been using the program
> a couple of weeks now, but I've never started it via a terminal. Lazy as
> I am I just created a custom action for Thunar, so I can simply right
> click on a videofile and then open it with vidcutter:

Noted :-)

> <action>
>     <icon>vidcutter</icon>
>     <name>Öffne mit Vidcutter</name>
>     <unique-id>1486424626017141-1</unique-id>
>     <command>vidcutter %f</command>
>     <description>Videodatei mit Vidcutter öffnen und
> bearbeiten</description>
> <patterns>*ts;*.mpg;*mpeg;*.mp4;*.mkv;*.avi;*.flv</patterns>
>     <other-files/>
>     <text-files/>
>     <video-files/>
> </action>

however, I often work out of 'mc' - yes, with videos ;-)

> Works fine and of course the classic drag & drop still works too ;-) At
> the moment I've no idea what could cause your grey preview window. So
> far I've not experienced something like that and I've opened & edited
> pretty much all sorts of different videofiles with vidcutter by now.
> That even includes some seriously damaged flv-videos Avidemux didn't
> like at all. No big issue for Vidcutter to cut out the good parts and
> save them correctly. If your video is indeed an MPEG-file, then it
> really should be no problem to load and edit them.
> Is there any chance that the issue is caused by the videofile itself?
> Maybe a broken/corrupt file? Any errors/problems when you play it with
> ffplay/MPlayer or open it with Avidemux? Is the preview with Avidemux
> also grey and does the same happen with other videos as well?

The video is not broken, but it is indeed peculiar, other tools have 
problems with this source. Not this particular problem, though. ffmpeg 
is actually the best tool to work with it, yes. I may try recoding the 
video first, then try to cut the commercials.

It is a recording from digital tv transmited via cable, mpeg-ts. 
mediainfo says:

ID                                       : 100 (0x64)
Complete name                            : Cine  El Hobbit  La batalla de los cinco ejercitos.mpeg
Format                                   : MPEG-TS  <=======
File size                                : 2.70 GiB
Duration                                 : 2 h 48 min
Overall bit rate mode                    : Constant
Overall bit rate                         : 2 300 kb/s

ID                                       : 481 (0x1E1)
Menu ID                                  : 1 (0x1)
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High at L3
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 4 frames
Codec ID                                 : 27
Duration                                 : 2 h 48 min
Bit rate                                 : 1 863 kb/s
Width                                    : 720 pixels
Height                                   : 576 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 25.000 FPS
Standard                                 : PAL
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : MBAFF
Scan type, store method                  : Separated fields
Scan order                               : Top Field First
Bits/(Pixel*Frame)                       : 0.180
Stream size                              : 2.19 GiB (81%)
Color range                              : Limited
Color primaries                          : BT.601 PAL
Transfer characteristics                 : BT.470 System B, BT.470 System G
Matrix coefficients                      : BT.601

> That's how it should look like: http://i.imgur.com/7IV5a5m.png (SD; 576i)

Ah, then the slider is also blank, I thought it would display snapshots.

> Another option and very likely the most  promising is to contact the
> developer (a friendy guy) of Vidcutter directly on github:
> https://github.com/ozmartian/vidcutter/issues

Yes, certainly, I can try that.

I have been very interested for years in a video tool that does no 
recoding of the stream, just to cut or join pieces.

The other tool that I'm interested in is ProjectX.cvs, but it can't load 
these files, something I don't remember the name is way too big. 
Unfortunately the home site appears to be German only, so I don't know 
how to communicate with them.

- -- 
        Carlos E. R.

        (from 42.2 x86_64 "Malachite" (Minas Tirith))

Version: GnuPG v2


More information about the Packman mailing list