[packman] Packaging request - VidCutter

Gerhard Kühbauer vienna550 at hotmail.com
Tue Feb 14 20:51:20 CET 2017

Hello everybody and first of all let me say a big, big thank you to the 
Packman-Team and especially Luigi Baldoni for adding Vidcutter so 
quickly to the packman-repo and making it easily available for all the 
openSUSE/SUSE-users out there. Thanks a lot for all your efforts and let 
me assure you that they are really appreciated!

Am 2017-02-14 um 19:16 schrieb Carlos E. R.:
> However, it does not work well here.
> If on the terminal I do "vidcutter video.mpeg" it crashes...
> The same movie opens from the menu, but the display of the movie is 
> grey. If I move the slider I see grey shapes on the display, but the 
> slider itself is empty. If I hit "play" it does play. If I move the 
> slider with the keyboard, most frams desplay grey content with some 
> weird shapes, and now and then a frame from the movie.
> This way I can not seek the sections to cut...

I'm afraid I'm really not much help here, but I can at least confirm 
that starting Vidcutter from a terminal with vidcutter mymovie causes 
the program to crash. If you provide the full path - for example: 
vidcutter /media/VIDEO/mymovie then vidcutter starts and opens the video 
correctly. Tried that half a dozen times with various videofiles in the 
last minutes, it always worked. Strange, but maybe it is an acceptable 
workaround for you till the issue is fixed. I've been using the program 
a couple of weeks now, but I've never started it via a terminal. Lazy as 
I am I just created a custom action for Thunar, so I can simply right 
click on a videofile and then open it with vidcutter:

     <name>Öffne mit Vidcutter</name>
     <command>vidcutter %f</command>
     <description>Videodatei mit Vidcutter öffnen und 

Works fine and of course the classic drag & drop still works too ;-) At 
the moment I've no idea what could cause your grey preview window. So 
far I've not experienced something like that and I've opened & edited 
pretty much all sorts of different videofiles with vidcutter by now. 
That even includes some seriously damaged flv-videos Avidemux didn't 
like at all. No big issue for Vidcutter to cut out the good parts and 
save them correctly. If your video is indeed an MPEG-file, then it 
really should be no problem to load and edit them.

Is there any chance that the issue is caused by the videofile itself? 
Maybe a broken/corrupt file? Any errors/problems when you play it with 
ffplay/MPlayer or open it with Avidemux? Is the preview with Avidemux 
also grey and does the same happen with other videos as well?

That's how it should look like: http://i.imgur.com/7IV5a5m.png (SD; 576i)

Another option and very likely the most  promising is to contact the 
developer (a friendy guy) of Vidcutter directly on github: 

More information about the Packman mailing list