[packman] Azureus-

Vahis waxborg at gmail.com
Thu Jan 25 17:39:02 CET 2007

Toni wrote:
> Am Donnerstag, 25. Januar 2007 11:55 schrieb harryc:
>> The latest Azureus is broken. I'd be glad to work with the packager to
>> resolve it. Here's some examples at our forum of this problem;
>> http://www.suseforums.net/index.php?showtopic=30245&hl=packman
>> http://www.suseforums.net/index.php?showtopic=30220&hl=packman
> hm, the link gives for me:
>     IPS Driver Error
>     There appears to be an error with the database.
>     You can try to refresh the page by clicking here 
> ok, so without more informations ... no solutions :)
> otherwise, note: All our packages are compiled, builded against a stock-SuSE 
> and/or packman packages. So if you update your system with packages from 
> several repositories, you'll end in problems. 
> Obviously, the latest java update changed something. 
> So my advise (a shoot in the dark forest without more information):
> Start a security related java-programm ONCE as root, it will create some 
> entries in directories a user is not allowed to write, and then all 
> java-programs should run again.
> This issue is as old as java, and can be found on the sun-homepage and 
> mailing-lists.
>> Thanks for your time,
>> Harry
> have fun 
> Toni
> _______________________________________________
> Packman mailing list
> Packman at links2linux.de
> http://www.links2linux.de/cgi-bin/mailman/listinfo/packman

In my case running Azureus as root did not help.
What would be a "security related java program"?

The whole history of the error in my case was this:

I had Azureus 2.5 latest beta from Packman running.

Then there was a java security update.

Azureus didn't run anymore, it started up and as soon as I tried to do
anything with it it crashed and died.

I removed the java security updates and Azureus ran again.

Then came the new Azureus 3.0.5 beta from Packman, which I installed and
it ran fine.

I applied the java patches again and Azureus went south.

I removed the patches and Azureus 3.0.5 beta runs just fine.

All the installations I have made as root obviously.
Running Azureus I have tried as user and as root.

The results are the same in all cases.

So I refrain from applying the java patches and everything is fine.


More information about the Packman mailing list