[packman] yt-dlp 2022.08.08 broken on 15.3
Carlos E. R.
robin.listas at telefonica.net
Thu Aug 11 13:35:16 CEST 2022
On 2022-08-11 13:25, Masaru Nomiya wrote:
> In the Message;
> Subject : Re: [packman] yt-dlp 2022.08.08 broken on 15.3
> Message-ID : <d1abe7f4-94d3-e7bd-dd28-b7007d7bb6a6 at telefonica.net>
> Date & Time: Thu, 11 Aug 2022 12:57:20 +0200
> [CER] == "Carlos E. R." <robin.listas at telefonica.net> has written:
> MS>>> Exception: You are using an unsupported version of Python. Only Python
> MS>>> versions 3.7 and above are supported by yt-dlp
> MN>> That's all there is to it.
> MN>> In other words, use it with python37 or higher python3.
> CER> That is not up to us (plain users), Leap has 2.7 and we can not
> CER> change it.
> You are mistaken.
> What yt-dlp needs is python3, not python.
> CER> Thus, this package can not be published as is.
> CER> I just tried to revert the update, but there are no older
> CER> versions available. I have a local copy of 2022.07.18 and
> CER> reverted to that one.
> python3 in Leap 15.3 is python3.6, right?
> yt-dlp requires python3.7 or higher.
Then the package must have that dependency.
> The solution in Leap 15.3 is installing python 3.8 (3.7 isn't
> availlable, is it?) and use update-laternatives.
That is not trivial.
Would not make that default break other tools already installed?
In fact, python3 is installed in my machine.
Machine is up to date.
Cheers / Saludos,
Carlos E. R.
(from 15.3 x86_64 at Telcontar)
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 203 bytes
Desc: OpenPGP digital signature
More information about the Packman