[packman] chromium-ffmpeg-extra in OpenSUSE Tumbleweed: how is libffmpeg.so loaded?

Dave Plater davejplater at gmail.com
Sun Jan 17 07:18:50 CET 2021

On 1/15/21, Dimitrios Apostolou <jimis at gmx.net> wrote:
> Hello list, please CC me in your replies as I'm not subscribed.
> I'm facing issues with codecs on chromium (Video calls not working on
> Microsoft Teams). Packages I have installed:
> $ rpm -qa|grep chromium
> chromium-87.0.4280.141-1.1.x86_64
> chromium-ffmpeg-extra-69.0.3497.100-2.24.x86_64
> It seems that chromium-ffmpeg-extra contains only one significant file:
> /usr/lib64/chromium-ffmpeg-extra/libffmpeg.so
> How does the `chromium` binary load this file? AFAICT it never loads it.
> Here is what I tried:
> + Run `ldd` for /usr/lib64/chromium/chromium and all the .so libraries it
>    loads. "libffmpeg.so" is not listed anywhere
> + Run `strings` for all of the above, still not listed.
> + `strace` chromium as such:
>    strace -ff -s 128  chromium --enable-logging=stderr --v=2 --debug
>    Still `libffmpeg.so` is not listed anywhere.
> + Up to this point, I'm not so surprised as the shell script
>    /usr/bin/chromium sets LD_LIBRARY_PATH to /usr/lib64/chromium
>    which has nothing to do with /usr/lib64/chromium-ffmpeg-extra.
>    How is chromium supposed to know that path?
> + But even setting LD_LIBRARY_PATH explicitly to
>    /usr/lib64/chromium-ffmpeg-extra does not help, libffmpeg.so is still
>    not getting loaded.
> Any ideas?
> Thank you in advance,
> Dimitris
> _______________________________________________
> Packman mailing list
> Packman at links2linux.de
> https://lists.links2linux.de/cgi-bin/mailman/listinfo/packman

I'm not sure which codec is involved in "Microsoft Teams" but the
summery for chromium-ffmpeg-extra says "Extra ffmpeg codecs for
browsers based on Chromium" the actual ffmpeg libraries libavcodec
libavformat etc are required by chromium itself. If you know the
specific codec you can find out what your ffmpeg provides with "ffmpeg
-codecs" if you don't have the packman versions of libavcodec, the
actual package that Tubleweed chromium uses is libavcodec58_91, then
this may be your problem.


More information about the Packman mailing list