[packman] chromium-ffmpeg-extra in OpenSUSE Tumbleweed: how is libffmpeg.so loaded?

Dimitrios Apostolou jimis at gmx.net
Fri Jan 15 09:40:16 CET 2021

Hello list, please CC me in your replies as I'm not subscribed.

I'm facing issues with codecs on chromium (Video calls not working on
Microsoft Teams). Packages I have installed:

$ rpm -qa|grep chromium

It seems that chromium-ffmpeg-extra contains only one significant file:

How does the `chromium` binary load this file? AFAICT it never loads it.
Here is what I tried:

+ Run `ldd` for /usr/lib64/chromium/chromium and all the .so libraries it
   loads. "libffmpeg.so" is not listed anywhere

+ Run `strings` for all of the above, still not listed.

+ `strace` chromium as such:

   strace -ff -s 128  chromium --enable-logging=stderr --v=2 --debug

   Still `libffmpeg.so` is not listed anywhere.

+ Up to this point, I'm not so surprised as the shell script
   /usr/bin/chromium sets LD_LIBRARY_PATH to /usr/lib64/chromium
   which has nothing to do with /usr/lib64/chromium-ffmpeg-extra.
   How is chromium supposed to know that path?

+ But even setting LD_LIBRARY_PATH explicitly to
   /usr/lib64/chromium-ffmpeg-extra does not help, libffmpeg.so is still
   not getting loaded.

Any ideas?

Thank you in advance,

More information about the Packman mailing list