[packman] regression: handbrake-unstable stops working (x264)

Stefan Seyfried stefan.seyfried at googlemail.com
Sat Nov 22 21:13:32 CET 2014

Am 19.11.2014 um 23:23 schrieb Dominik Kopp:
> Stefan Seyfried wrote:
>>> HandBrakeCLI -i /home/dom/video/test2/1min.mpg  -o output.m4v -e x264

> Test video: http://koppnik.de/dvbcut/1min.mpg
> I switched to the released 0.9.9, reinstalled some gstreamer and libav 
> packages and handbrake works now mostly. Typical videos (DVB-S recordings) 
> are working with handbrake, but the test video above not.
> (the test video worked up to version 0.9.8)

Ok, This has nothing to do with x264 (if you omit "-e x264", it will
fail exactly the same), it fails while decoding the video.

Unfortunately, I am not familiar with libav.

I tried the obvious fix (updating to the latest libav-10.x release) but
that did not change anything.
I also tried to update to libav-11, but that is not easily possible
because of the patches applied by handbrake.

To solve this issue, it's probably best if you go to handbrake upstream
and report your problem there. With the nice small test video, the issue
should be easily reproducible for them. If it's not, then we can still
start looking into issues which might come from packman patches / packaging.

> and here's the 160 byte file when the assertion fails:
> http://koppnik.de/dvbcut/output.m4v

That's just empty with an MP4 v2 header.

Best regards,

Stefan Seyfried

"For a successful technology, reality must take precedence over
 public relations, for nature cannot be fooled." -- Richard Feynman

More information about the Packman mailing list