[packman] regression: handbrake-unstable stops working (x264)

Dominik Kopp my at kabelfunk.de
Wed Nov 19 23:23:03 CET 2014

Stefan Seyfried wrote:
>> HandBrakeCLI -i /home/dom/video/test2/1min.mpg  -o output.m4v -e x264
>> ...
>> [13:37:22] encx264: encoding at average bitrate 1000
>> x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX AVX2
>> [13:37:22] mpeg2video: "Chapter 1" (1) at frame 0 time 4666
>> x264 [info]: profile High, level 3.0
>> [13:37:22] sync: first pts is 4666
>> Encoding: task 1 of 1, 52.07 %HandBrakeCLI: libavcodec/mpegvideo.c:353:
>> mpeg_er_decode_mb: Assertion `ref == 0' failed.
>> Abgebrochen
> This is not a segfault, this is an failed assertion. Have you reported
> this to upstream handbrake? Especially if it is also happening in
> released version 0.9.9?
> Is the test video available somewhere (for reproducing the issue)?

Test video: http://koppnik.de/dvbcut/1min.mpg
I switched to the released 0.9.9, reinstalled some gstreamer and libav 
packages and handbrake works now mostly. Typical videos (DVB-S recordings) 
are working with handbrake, but the test video above not.
(the test video worked up to version 0.9.8)

and here's the 160 byte file when the assertion fails:

More information about the Packman mailing list