[packman] raspberrypi-userland

Jörg Lorenzen joerg.lorenzen at ki.tng.de
Tue Dec 16 14:47:51 CET 2014

Hi Packman Team,

I have a general question about ARM repositories for openSUSE >= 13.1 
in project Essentials.
Why are these repositories depending on 
Although raspberrypi-userland and raspberrypi-userland-devel are 
preferred in config for Essentials,
there are build errors for arch armv6l due to conflicts, e.g. build of 
package audacity ends with following message:

file /usr/lib/libEGL.so conflicts between attempted installs of 
and raspberrypi-userland-2014.10.17-4.2.armv6hl

I think the problem is caused by package Mesa-devel which requires 
Mesa-libEGL-devel = <version>,
where <version> is the version of Mesa and not of raspberrypi-userland.

For some packages I made a workaround to build them on armv6l, I 
explicit added packages
Mesa-libEGL1, Mesa-libEGL-devel, Mesa-libGLESv1_CM1, 
Mesa-libGLESv1_CM-devel, Mesa-libGLESv2-2
and Mesa-libGLESv2-devel as BuildRequires, but this can't be a solution 
for all packages.

Wouldn't it be better to remove 
openSUSE.org:devel:ARM:<distribution>:Contrib:RaspberryPi from 
anyone you wants to install raspberrypi-userland instead of the 
original packages can add the repository
e.g. via YaST and then replace the the affected packages.


More information about the Packman mailing list