[packman] libsndfile

Cristian Morales Vega cmorve69 at yahoo.es
Sun Mar 6 20:52:56 CET 2011

2011/3/5 Pascal Bleser <pascal.bleser at opensuse.org>:
> On 2011-03-05 09:12:42 (+0100), Cristian Morales Vega <cmorve69 at yahoo.es> wrote:
>> Why should it be in Multimedia? It's in Essentials:
>> http://packman.jacobs-university.de/suse/openSUSE_11.3/Essentials/x86_64/
>> In fact... why should it be in Packman? openSUSE already comes with
>> libsndfile 1.0.20.
> Yes, indeed, except Evergreen_11.1 and SLE_11.
> Right now, in Essentials, it's a _link to multimedia:libs on
> OBS.
> It's a bit sensitive because a lot of packages depend on it:
>   MPlayer
>   bs2b
>   fluidsynth
>   gstreamer010-bml
>   gstreamer010-buzztard
>   gstreamer010-plugins-bad
>   gstreamer010-plugins-bad-0.10.19
>   gstreamer010-plugins-good
>   gstreamer010-plugins-good-0.10.24
>   k3b
>   ladspa-pvoc
>   lame
>   libbluray
>   libcaca
>   libquicktime
>   mpg123
>   openal-soft
>   phonon-backend-vlc
>   projectM-pulseaudio
>   smplayer
>   taglib-extras
>   twolaame
>   vlc
>   xine-lib
> I'd say that, right now, it's too sensitive to muck around with
> it but yeah, there is most probably no need for it to be in
> Essentials (except maybe for Evergreen and SLE). Would have to
> check whether multimedia:libs/libsndfile differs from the
> package that ships with openSUSE in any way.
> TBH it's not on the top of my TODO list right now, but thanks
> for noticing :)

I'm going to try to at least clean openSUSE:11.4. The openSUSE:11.4
and multimedia:libs versions of libsndfile are bit identical, so it's
safe. If at some point a package requires a newer version of
libsndfile than the one found in openSUSE 11.4 it would be good that
whoever enables the build adds in the OBS package description a
comment explaining why it's enabled (see cdparanoia and schroedinger
descriptions). This way there would be some control about this kind of

More information about the Packman mailing list