[packman] [PM] libxine1-1.1.19-2.pm.48.19 (openSUSE 11.2/i586)

Manfred Tremmel manfred at links2linux.de
Thu Feb 24 20:49:54 CET 2011

Am Donnerstag, 24. Februar 2011 schrieb Karl Scheel:
> Dear Mr. Tremmel:
> Before upgrading xine on one of my x86 machines from your website, I
> obtained the source-tarball of the same version from the Xine-hq
> website. I was able to make my own RPMs using the "rpmbuild -ta"
> command. The build-process was completed without any problems on my
>  old AMD K6-III+ machine that runs openSUSE 10.2, creating the
>  following packages (the first two for this release of openSUSE):
> libxine1-1.1.19-0.i586.rpm,
> libxine-devel-1.1.19-0.i586.rpm,
> libxine1-1.1.19-0.src.rpm

Yes, the included spec file doesn't build any subpackages exepted the -
devel package. So libxine1 package includes all modules which are build.

> I then took the source rpm from that particular build, and rebuilt
>  the libxine1 and libxine-devel packages on one of my newer Pentium
>  IV machines running openSUSE 11.2 using the "rpmbuild --rebuild"
>  command, giving me the first two packages of the three listed above
>  for this newer release of openSUSE. I then attempted to install them
>  on that newer machine. However, upon my doing so, a warning window
>  opened, stating that the libxine1 conflicted with both of the
>  following xine-plugins:
> libxine1-pulse,
> libxine1-gnome-vfs

SUSE and Packman exclude some modules which are not used by many users 
or cause a lot of dependencies.

> So, I uninstalled them, and tried again. This allowed the
>  installation of my own xine-build to proceed; however, upon its
>  completion, I noticed that the cool audio clip could no longer be
>  heard whenever I logged-into KDE 4. Strangely-enough, xine was
>  working perfectly (i.e., both sound and video) via the openSUSE
>  version of xine-ui that was already installed (and the mplayer2
>  codecs I installed). However, this missing KDE sound-effect
>  significantly subtracted from "coolness-factor" of this machine, so
>  naturally, I HAD to start searching for a solution to this problem.
> Upon my examination of the file-lists of these two plugins, I
>  discovered that they each contained only one file:
> xineplug_ao_out_pulseaudio.so,
> xineplug_inp_gnome_vfs.so


> Upon my examination of the file-list of the libxine1 version that I
> built myself, I discovered the reason for the conflict: These files
>  were already included within that version. These two plugins were

Maybe, depends on which -devel packages you had installed at build time. 
The spec file inside the tarball is distribution independend so it can't 
contain BuildRequires entrys and it can't make sure everything required 
is available.

>  included by-default when I compiled xine myself (i.e., provided that
> libpulse-devel and gnome-vfs2-devel were installed). However, for
>  some reason unknown to me, they were left-out of the openSUSE
>  version of xine, and compiled separately as individual packages.
>  This left me puzzled: If these plugins were already included in my
>  own build of xine, then why didn't that cool KDE sound-effect play
>  as it was supposed to? And why were they taken-out of the standard
>  xine-build?

There are different video and audio output plugins available in the 
libxine tarball. I don't know which one is used on your system. I use 
the alsa output plugin.

> After wasting almost a day trying to find a solution to this problem
>  on my own, I decided to downgrade my installation of xine back to
>  the original openSUSE version, and reinstall the two plugins; this
>  brought the machine back to its original state, where that cool
>  sound-effect could be heard again. Then, I went to your website and
>  performed the 1-click installation of xine on the newer machine.
>  Miraculously, upon its completion, the newest Packman version of
>  xine worked perfectly, AND that cool KDE sound-effect was still able
>  to play. VERY COOL!
> HOW DID YOU DO IT, MR. XINE-PACKAGER? And what exactly occurs when
>  the separate openSUSE versions of those two xine-plugins are built
>  that does not occur during a standard xine-build (which includes
>  them), besides the additional separate entries within the rpm
>  database?

It's simply created as a separate package. I don't think it has anything 
to do with your problem.

>  There must be SOMETHING that is different, that affects
>  the functioning of the xine-backend to the KDE 4 sound-server (which
>  incidently, is supposed to use alsa, not pulse: libpulse is supposed
>  to be for compatibility with GNOME applications.)!

gnome-vfs has nothing to do with audio and pulse-audio may or may not be 
used on your system. On my system pulse-auido isn't used and that's 

> Another thing puzzles me: Although I was able to configure, compile,
>  and install the xine source-tarball in the standard /usr/local
>  prefix on the newer machine using the "./configure, make, and make
>  install" commands, whenever I attempted to use the rpmbuild command
>  on it, I would get the following error-message, regardless of the
>  version of libxine1 source-tarball used:
> "error: unable to read specfile"
> However, this did not occur when I did the same thing on the older
> machine; the rpmbuild utility was able to read the specfile just fine
> when the command was entered using exactly the same syntax, and same
> tarball. This problem seems to be just with libxine1, not xine-ui; on
> the newer machine, the rpmbuild command works fine with xine-ui. What
> exactly is behind this VERY-STRANGE behaviour in openSUSE 11.2?

Use the packman package.

Machs gut    | http://www.iivs.de/schwinde/buerger/tremmel/

Manfred      | http://packman.links2linux.de/

More information about the Packman mailing list