[packman] gstreamer010-plugins-base problem (was: Re: gstreamer010-plugins-ugly on 11.0/x86_64 broken?)

"Andrés G. Aragoneses" knocte at gmail.com
Thu Sep 11 11:59:07 CEST 2008

BTW, now I have the problem fixed, although I would like to contribute 
something upstream in order to avoid the same problem for people in the 

I discovered the issue because:

- To remind you: christine was working perfectly when playing MP3, but 
totem and Banshee not.
- I contacted christine-devel list, and they gave me some hints. It 
turns out christine allows you to select the audiosink used when using 
gstreamer. It was configured by default to use autoaudiosink. Changing 
it to alsasink or esdsink didn't change anything (it still worked), but 
changing it to gconfaudiosink it made it crash (remember: totem didn't 
crash but played no sound, although the pretty "music" visualization 
worked; and Banshee didn't worked, it jumped to the next song).
- I looked for more info on audiosinks and found this bug which had very 
useful information:
- This made me discover that my problems get fixed when going to Gnome 
Control Center -> System -> Sound, and selecting there "Autodetect" 
instead of "Default (Custom)".

So my questions are:
a) We should have a way to detect this situation in all the players, 
right? Is this feasible?
b) We should change the default setting of distros to be "Autodetect" 
instead of "Default (Custom)", right?
c) Anyway, I guess that my problem with "Default (Custom)" is still a 
bug, right? But where is the bug?:
* Packman packaging?
* GStreamer?
* Pulseaudio/alsa/...?
* All the players?
* Other?

What do you think about a) and b)? Should we open bugs for them? And how 
can I debug the c) issue?



Andrés G. Aragoneses wrote:
> Toni wrote:
>> Am Donnerstag, 11. September 2008 schrieb Andrés G. Aragoneses:
>>> Toni wrote:
>>>> Am Dienstag, 9. September 2008 schrieb Andrés G. Aragoneses:
>>>>> Investigating more about this issue I'm having, I have reached a point
>>>>> where maybe I have found a problem in a packman package:
>>>>> gstreamer010-plugins-base, because I've downloaded totem's SVN version,
>>>>> and when running ./autogen.sh I get the following error:
>>>>> configure: error:
>>>>> 	Cannot find required GStreamer-0.10 plugin 'playbin'.				It should be
>>>>> part of gst-plugins-base. Please install it.
>>>>> However, I have the package "gstramer-0_10-plugins-base 0.10.20-42.pm.1
>>>>> (x86_64)" already installed successfully in my system (I have already
>>>>> tried to reinstall it).
>>>>> Any ideas about this problem?
>>>> we use the packman packages to compile and build all other packages... so
>>>> the plugin is not missing :)
>>>> a simple rpm -ql or a webpin playbin shows you that it is part of the
>>>> package.
>>> Ok, the plugin is there, what's not there is, actually, the tool to
>>> inspect plugins: gst-inspect010. Do you know why I am lacking this?
>>> I'll contribute a patch to totem's configure.in file to check for this.
>> again: use webpin to lok-up programs/packages:
>> webpin gst-inspect
>>    10 results (5 packages) found for "gst-inspect" in openSUSE_103
>> * gstreamer010: Streaming-Media Framework Runtime
>>    - 0.10.13 [suse-oss]
>>      >> /usr/bin/gst-inspect
>>    - 0.10.14 [BS::home:/luneo7]
>>      >> /usr/bin/gst-inspect
>> * gstreamer-0_10-debuginfo: Debug information for package gstreamer-0_10
>>    - 0.10.20 [packman]
>>      >> /usr/lib/debug/usr/bin/gst-inspect-0.10.debug
>> * gstreamer-0_10-utils: Streaming-Media Framework Runtime
>>    - 0.10.20 [packman | BS::home:/FunkyPenguin:/Cheese]
>>      >> /usr/bin/gst-inspect-0.10
>>    - 0.10.19 [BS::GNOME:/STABLE]
>>      >> /usr/bin/gst-inspect-0.10
>> * gstreamer-utils: Streaming-Media Framework Runtime
>>    - 0.10.20 [packman | BS::home:/FunkyPenguin:/Cheese]
>>      >> /usr/bin/gst-inspect
>>    - 0.10.19 [BS::GNOME:/STABLE]
>>      >> /usr/bin/gst-inspect
>> * gstreamer010-debuginfo: Debug information for package gstreamer010
>>    - 0.10.14 [BS::home:/luneo7]
>>      >> /usr/lib/debug/usr/bin/gst-inspect-0.10.debug
>> so you need gstreamer-0_10-utils package.
>> webpin is also available online:
>> http://packages.opensuse-community.org/
> I thought webpin was *only* available online, thanks, this is cool.
> I've submitted a patch:
> http://bugzilla.gnome.org/show_bug.cgi?id=551774
> 	Andrés
> -- 

More information about the Packman mailing list