[packman] Status of Tora for SuSE 10.3?

John Emmer jemmer at cj.com
Fri Mar 28 18:49:06 CET 2008

On 03/27/2008 Rainer Lay wrote:
> currently, tora is rewritten based on qt4 an qscintilla version 2.
> This can be compiled on openSUSE 10.3 and I am using it, like some 
> other guys too.
> The package only requires the mentioned libs, but not with a specific 
> version (although I am using the mentioned versions).
> If you have problem installing/using the rpm, I think you should have 
> a look there.
> And please try the newer version. 

I realized that I was reading the YaST error report wrong, and that it was really complaining that I didn't have oracle instant client.  However, I do have a full oracle installation and full oracle client installed with all the appropriate directories on my LD_LIBRARY_PATH.  But just to be sure, I downloaded and installed oracle-instantclient-basic- I also updated tora with the latest tora-svn-1.3.999-0.pm.r2639.0.i586.rpm and updated libqt and libqscintilla at the same time (just updating with the same version).  YaST had no complaints this time. But I don't really think the problem was ever with the oracle libraries, as the missing symbol definitely looks like a problem with qscintilla.  

When I run tora, I still get: tora: symbol lookup error: tora: undefined symbol: _ZN13QsciScintilla16staticMetaObjectE

Is there anything I can do to generate any more useful information about this?  


John Emmer
Senior Software Engineer

Commission Junction, a division of ValueClick, Inc.
30699 Russell Ranch Road, Suite 250 . Westlake Village, CA 91361
phone 818 575 4618 . fax 818 575 4501

Any disclosure, copying, distribution, posting or use of the contents of this information is prohibited and may be unlawful. This e-mail may contain proprietary or confidential information and is for the sole use of the intended recipient(s). Thank you.

More information about the Packman mailing list