[packman] gstreamer010-plugins-ugly on 11.0/x86_64 broken?

"Andrés G. Aragoneses" knocte at gmail.com
Mon Aug 18 13:45:26 CEST 2008

Toni wrote:
> Am Montag, 18. August 2008 schrieb Andrés G. Aragoneses:
>> Toni wrote:
>>> Am Montag, 18. August 2008 schrieb Andrés G. Aragoneses:
>>>> Toni wrote:
>>>>> Am Montag, 18. August 2008 schrieb Andrés G. Aragoneses:
>>>>>> Since some weeks ago, I noticed that I can no longer playback mp3.
>>>>>> Banshee steps to the next, and Totem plays it without sound. Any ideas
>>>>>> on what may be the problem? As I said, this was working for me some
>>>>>> weeks ago.
>>>>> Since weeks ago, the sun is shining or not ...
>>>>> What kind of answer did you expect without providing the necessary
>>>>> informations ?
>>>>> what packages are installed ?
>>>>> "since weeks ago"  ... when did you change something ? What did you
>>>>> change ?
>>>> Sorry but I don't remember if I installed updates from packman, normally
>>>> I accept what I see in my package manager. Is there a way to find out?
>>>> (Using openSUSE11.0)
>>>> The version of plugins-ugly that I have is:
>>>> 0.10.8-42
>>>> The gstreamer packages I have installed (the ones with "i" in the row)
>>>> are: http://monoport.com/36895
>>> this info is "worthless" without the version and release-numbers.
>>> in a console call:
>>> rpm -qa | grep gstreamer
>> Result:
>> gstreamer-0_10-lang-0.10.20-42.pm.1
>> gstreamer-0_10-devel-0.10.20-42.pm.1
>> gstreamer-0_10-plugins-base-devel-0.10.20-42.pm.1
>> gstreamer-0_10-plugins-bad-lang-0.10.7-42.pm.1
>> gstreamer-0_10-0.10.20-42.pm.1
>> gstreamer-0_10-plugins-good-0.10.8-42.pm.1
>> gstreamer-0_10-plugins-ugly-0.10.8-42.pm.1
>> banshee-1-backend-engine-gstreamer-1.2.1-9.1
>> gstreamer-0_10-plugins-bad-0.10.7-42.pm.1
>> gstreamer-0_10-doc-0.10.20-42.pm.1
>> gstreamer-0_10-ffmpeg-0.10.4-42.pm.1
>> gstreamer-0_10-plugins-ugly-lang-0.10.8-42.pm.1
>> libgstreamer-0_10-0.10.20-42.pm.1   <====
>> gstreamer-0_10-plugins-base-0.10.20-42.pm.1
>> gstreamer-0_10-pulse-0.9.7-42.pm.1
>> libgstreamer-0_10-0-0.10.19-16.1   <=====
>> gstreamer-0_10-plugins-base-lang-0.10.20-42.pm.1
> so you have installed TWO different libgstreamer-0_10 packages (marked with 
> <==)

Ok, I'll try to remove one, and if it still doesn't work, I'll reinstall 
it and remove the other one, and report you back.

> and I think the banshee-1-backend is linked against the 0.10.19 version of 
> gstreamer. As banshee is not a packman package I can't recreate it with a 
> libsgstreamer-0.10.19 linkage.
> (just a sidenote: you need the *-devel packages only for compiling other 
> packages, otherwise you can deinstall them savely)

I know, I have some devel packages installed because I usually build 
banshee from trunk for developing purposes.

>>> other candidates are missing plugins, liboil and/or a mixture of packages
>>> from
>> rpm -qa | grep liboi
>> liboil-devel-0.3.15-0.pm.1
>> liboil0-0.3.15-0.pm.1
>> (Yesterday I uninstalled one liboil packaged called just "liboil",
>> instead of liboil0, but that didn't help, same behaviour now and then.)
> I guess you are missing the gstreamer-0_10-fluendo-* packages from packman.
> You can also try to play other formats (ogg, wav, ..) to see if only mp3 is 
> related.

Yesterday when researching about the issue, I tried to install them and 
it still didn't work (also tried to install them after removing the ugly 
plugin, in case they couldn't co-exist, and it still didn't work).

I'll try wav files and report back.

>>> other repositories. ...
>> Yeah, maybe what happened is that an OpenSUSE update (not a packman
>> update) broke this...
> so with the given list on new installations, you can go back step by step to 
> find out which package breaks your system.

Mmm, but some of them are updates, not new packages, so how can I 
rollback to older versions in order not to remove them completely?

>>> call your application within a console and look for (error-)messages.
>> Yes, that was what I did for Banshee and I only got:
>> [Error 12:48:38.277] GStreamer stream error: Failed
>> I didn't test with Totem so, now that I test, I see that there's no
>> error at all in the console. Any other gstreamer media player I could test?
> christine is a simple fat-free player, you can find it also in the packman 
> repository.

I'll try that.

>>> As a hint:
>>> to check what you have installed in the last time, you can call:
>>> rpm -qa --last or
>>> rpm -qa --last | less
>>> and you'll receive a list in descending order (newest installed package
>>> is the first!)
>> Ok, last ones I installed:
>> http://monoport.com/36902
>> Maybe the pulseaudio updates are related?
> perhaps, the pulseaudio stuff needs AFAIK some extra setups for sound (I don't 
> use it, so I can't help here). If you don't know how to setup pulseaudio, try 
> to uninstall the pulseaudio stuff (but don't force anything, as some apps 
> needs libpulse*)

That sounds scary.




More information about the Packman mailing list