[packman] [PM] smplayer-beta 0.5.61 (openSUSE 10.3/x86_64)

Pascal Bleser pascal.bleser at skynet.be
Thu Oct 11 00:12:39 CEST 2007

Hash: SHA1

William Pfeffer wrote:
> When i run your rpm I get a segmentation fault and the same happens if I
> dl and rebuild your src.rpm. But if I dl the tar file
> http://internap.dl.sourceforge.net/sourceforge/smplayer/smplayer-0.5.61.tar.bz2
> and compile it it runs fine.
> Now I really don't know much about building programs but I'm starting to
> think  my issues with make and qmake and which version my Suse is
> actually using.I had this with qps where Suse defaults to qmake v4 and
> it seg faulted but when I forced qmake v3 it worked fine. With smplayer
> my make defaults to v3 and using it with the tar compiles and runs fine
> (I'm guessing your's uses make v4)

OK, so you're building against Qt3 and not Qt4.
Weird thing is that the author states that for the beta versions Qt3
isn't supported any more, which is why I've built it against Qt4.

I'll try to investigate but I don't have much time for it.

> Maybe I'm missing some qt4 rpm's or my paths are messed up and that's
> what's causing  the problem but I thought you all might be interested in
> my experience as I might not be unique.

No, hardly. Well you can also just use "smplayer" instead of
"smplayer-beta". The former definitely works ;)

- --
  -o) Pascal Bleser     http://linux01.gwdg.de/~pbleser/
  /\\ <pascal.bleser at skynet.be>       <guru at unixtech.be>
 _\_v The more things change, the more they stay insane.
Version: GnuPG v1.4.5 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org


More information about the Packman mailing list