[packman] Re: [PM] last-exit 4.0 (openSUSE 10.2/x86_64)

morgan.brassel at free.fr morgan.brassel at free.fr
Fri Mar 30 20:43:11 CEST 2007

Selon Toni <toni at links2linux.de>:

> <snip>
> > In fact, the file libX11.so is only present in the libX11 devel packages
> > for ALL architectures. This means last-exit won't start even on 586 if
> > this package is not installed, and it is not present in opensuse default
> > installation.
> >
> > A (pretty bad) solution would be to put the libX11 devel package in
> > last-exit dependencies. Another (maybe better) solution would be to
> > check for libX11.so.6 (installed on opensuse default installation)
> > rather than libX11.so.
> this is a "problem" of mono.
> you find often statements like  [DllImport("libX11")] which leads to a
> libX11.so ...
> the proposed solution on their mailinglist is to change the /etc/mono/config
> file with a proper mapping for such libs:
> <dllmap dll="libX11" target="libX11.so"/>
> should be
> <dllmap dll="libX11" target="libX11.so.6.2"/>
> anyway I uploaded a new package. Please give it a try.

Hi, I just upgraded last-exit to the new package last-exit-4.0-0.pm.2.x86_64.rpm
but I still get the same error message (I removed my libX11.so symbolic link and
the file is still asked by the last-exit command).

But maybe I didn't understand your message: do I need to edit the mono config
file manually?

Thanks for all,

> have fun
> Toni

More information about the Packman mailing list