[packman] Unsatisfied dependencies for lots of packages

Toni toni at links2linux.de
Sat Dec 29 22:53:51 CET 2007

Am Samstag, 29. Dezember 2007 schrieb Stefan Tittel:
> Hi!
> The SMART package manager has a nice feature, which shows dependency
> problems even for uninstalled packages ("Edit"->"Check All Packages"). On
> my system only the official SUSE repositories and Packman are active and
> using this feature shows a lot of Packman packages having unresolvable
> dependencies. For some of the packages I checked myself if SMART is right
> about it and it seems like SMART really has a point with what it's saying:
> Unsatisfied dependency: GuitarTeX2-3.1.1-0.pm.1 at noarch requires tetex
> Unsatisfied dependency: GuitarTeX2-3.1.1-0.pm.1 at noarch requires te_latex
this is correct, it requires really tetex to work:)
> Unsatisfied dependency: MPlayer-1.0rc2-1.pm.1 at i586 requires libx264.so.54
is in work, we've updated x264

> Unsatisfied dependency: SecureSkat-2.8-0.pm.2 at i586 requires libTMCG.so.1
yes, alos correct

> Unsatisfied dependency: SwingOSC-supercollider-0.56-0.pm.1 at noarch requires
> SuperCollider
yes, it requires SuperCollider. it is a Frontendfor it ...

> Unsatisfied dependency: autotest-0.1.658-6 at i586 requires
> postgresql-debuginfo Unsatisfied dependency: avogadro-0.2.0-6.pm.1 at i586
> requires libavogadro = 0.2.0
> Unsatisfied dependency: bsl-0.2.0-0.pm.2 at i586 requires libbtcore >= 0.2.0
> Unsatisfied dependency: cabel-0.85-0.pm.4 at i586 requires CsoundVST
> Unsatisfied dependency: cinelerra-2.1.cv1036-0.pm.2 at i586 requires
> libx264.so.54
is in work, we've updated x264

> Unsatisfied dependency: csound-5.07.0-0.pm.1 at i586 requires portmidi
yes, its true it requires package portmidi

> Unsatisfied dependency: dclib-devel-0.3.12-0.pm.1 at i586 requires
> libbzip2-devel Unsatisfied dependency: evad-0.0.2-0.pm.1 at i586 requires
> python-ncurses Unsatisfied dependency: flickrpc-0.2-0.pm.1 at i586 requires
> python-elementtree Unsatisfied dependency:
> fox16-debuginfo-1.6.31-0.pm.1 at i586 requires fox16 = 2.1.0-0.pm.14
his is correct as fox16 is a virtual package for a possible fox-replacement

> Unsatisfied dependency: libogmrip-devel-0.11.2-0.pm.1 at i586 requires
> libogmrip = 0.11.2
every devel package needs the corresponding shared lib ...

just to give some samples ...

> From what I see a real lot of Packman packages seem to be broken (in the
> sense that they can't be installed/upgraded because of unresolved
> dependencies). To me it seems like a good idea if packagers could use this
> SMART feature as a basic QA measure to minimize package breakage in the
> future.
h3h3, ok, so you believe in this feature, I don't ... and it is not an 
indicator for broken packages, see my comments from above. And I won't 
comment all of them... just to give you an idea.

> Thanks in advance for fixing these problems and a happy New Year to all of
> you!
have fun
> Regards,
> Stefan

More information about the Packman mailing list