[packman] Fwd: xvidcap rpm

Marian Hello m.hello at gmail.com
Fri Sep 22 16:01:14 CEST 2006


As Rainer recommended me write to packman at links2linux.de, So I'm doing this.

Bellow that's what I wrote formerly to Rainder. Also there is Rainer reply.
He recommends me to find .spec file for xvidcap. I found one
on http://story.idi.ntnu.no/suse/9.0-i386/packages/xvidcap/index.html. I
changed the version number in spec to 1.1.4rc1 and source to
%name-%version.tar.gz and tried:
rpmbuild -bb xvidcap.spec

But I've got the same error

I'm trully sorry for being "pain in the ass", but I can't help myself.

This is what I sent to Eainer:
I would like to ask you for latest xvidcap rpm package. I plan to record
some Xgl videos and I realized that xvidcap is probable the most suitable
for this.

I tried to compile it myself, but I failed. I also posted my troubles on
xvidcap forum, but I don't expect any help from it.
I will appreciate, if you would be so nice and find some time for creating
xvidcap-1.1.4rc1 (for SUSE 10.1).
Source code link: http://sourceforge.net/projects/xvidcap/

I'm also attaching my experience about compiling xvidcap here:

As there is no xvidcap-1.1.4rc1 rpm, I tried to compile it from source.

I have a problem with configure script in SUSE 10.1. I have all devel
packgages (including glibc) in my system, so I can't understand where the
problem is.

fragment of configure error:
> ----------------
> checking for av_rescale in -lavutil... no
> checking for img_convert in -lavcodec... no
> checking for av_write_header in -lavformat... no
> checking for lame_init in -lmp3lame... no
> To use mp3 audio codecs you need liblame/liblame-dev
> checking for pthread_mutex_init in -lpthread... no
> xvidcap requires libpthread for recording. This machine doesn't have the
> libraries and/or header files installed.
> ----------------

I though it's because the system variable $LIBS is not set in SUSE by
default! When I set with:
export LIBS=/usr/include
I get another error:
checking for C compiler default output file name... configure: error: C
compiler cannot create executables
See `config.log' for more details.

Any advices?
thx in advance

---------- Forwarded message ----------
From: Rainer Lay <rainer.lay at gmx.de>
Date: Sep 22, 2006 3:03 PM
Subject: Re: xvidcap rpm
To: Marian Hello <m.hello at gmail.com>

Hello Marian,

a) do you have a xvidcap.spec file?
  - if yes, please try "%configure" instead of "./configure"
  - if no, please get one. You can have a look at rpmseek.com
b) You set a library variable to header files. If you try something like
that, try "LIBS=/usr/lib". but all that is done with "%configure"
c) unforntunalty, I cannot build that rpm myself. If you do not succed,
please write to packman at links2linux.de

kind regards,

More information about the Packman mailing list