[packman] [multimedia] no cinelerra packaged

Felix Miata mrmazda at earthlink.net
Tue Jun 6 01:05:21 CEST 2017

Martin Herkt composed on 2017-06-05 23:12 (UTC+0200):

Thank you for your reply!

> Felix Miata wrote:

>> Anyone know if there's good reason it isn't there? Is there something better
>> for commercials removal that is there? I've yet to figure out the UIs
>> and/or prevent crashing or hangs using anything I've tried to remove
>> commercials from the h264 .ts files saved by my FTA satellite receivers.

> FFmpeg or mkvtoolnix (can do lossless cutting, need to specify time ranges), 
> Blender (has a very powerful NLE), maybe Kdenlive (no experience with it but I 
> hear it’s usable).

I'd already tried to use ffmpeg, but couldn't find an appropriate example to
follow. https://github.com/amiaopensource/ffmpeg-amia-wiki/wiki looked
promising, but I failed.

I did a bit better with
On 42.1 I tried avidemux-qt 2.5.6 after I sent my OP. It seems it might work if
I could figure out why I can only get sound out of the internal PC speaker that
the mixer can't make loud enough to be useful. So I tried 2.5.6 on 42.2. VLC in
42.2 works on the files I tried in Avidemux on 42.1, but in 42.2, 2.5.6 always
produces a popup error:

"File Error:

I opened Kdenlive 16.12.3 using MLT 6.4.1, but neither file open nor file new
produces a file picker that allows even to find any file I want to edit.

I got Handbrake to open one of my files, but if it's capable of removing pieces,
it's completely non-obvious how to start to go about it.

Openshot found and "imported" a file I want to edit. It has an automatic
tutorial, but it seems to think I want to paste files together, not remove parts
from a single file, and its tutorial is quickly over. Here too it's totally
non-obvious how to select a portion for removal, or even if it's possible, as
the target .ts file only shows up in a separate preview window, not the main
editing window, and only plays there at half speed.

VidCutter on the surface seems to be what I need, but its extraordinarily simple
UI doesn't seem to have any way to successfully FastFwd/FastRev or advance or
move backwards by frame to mark edit points. It has a frame bar, but clicks on
it either do nothing at all, or reset play to 0:00:00.

As you indicate, mkvtoolnix requires knowledge I don't yet have: how to
determine/establish/locate edit points.

Blender is another heavyweight, 116MB to install even after Kdenlive and all the
others with all their deps. It showed up in the graphics menu instead of
multimedia. Everything in its UI is too tiny to be usable, apparently glued to
96 DPI and assuming the user can read or even see 10px or smaller text, so I've
removed it and its 11 deps.

Any other suggestions from anyone?

In the mean time, I'm going to update to latest TW and see if Avidemux will work
on it better than on Leap.
"The wise are known for their understanding, and pleasant
words are persuasive." Proverbs 16:21 (New Living Translation)

 Team OS/2 ** Reg. Linux User #211409 ** a11y rocks!

Felix Miata  ***  http://fm.no-ip.com/

More information about the Packman mailing list