[packman] Kodi crash

Manfred Hollstein manfred.h at gmx.net
Fri Feb 3 12:07:59 CET 2023

Hi Eric,

On Fri, 03 Feb 2023, 11:57:24 +0100, Eric Schirra wrote:
> Am Freitag, 3. Februar 2023, 10:36:41 CET schrieb Manfred Hollstein:
> > Moin,
> > 
> > On Fri, 03 Feb 2023, 09:31:44 +0100, Stefan Botter wrote:
> > > Hi Eric,
> > > 
> > > On Thu, 2023-02-02 at 16:34 +0100, Eric Schirra wrote:
> > > > Since probably kodi version 20, kodi crashes under Leap 15.4.
> > > > Is this only happening to me or to others as well?
> > > 
> > > At least for my players kodi 20 is working without problem on 15.4. I
> > > have 4 instances, 2 are NUCs, one is an older Intel Celeron S with
> > > buildin graphics and the last one is my workstation with NVidia
> > > graphics.
> > 
> > Kodi runs very well for me, too. All my systems use Intel CPU based
> > graphics, mixture of DisplayPort, HDMI, and built-in Display with sound
> > passthru and without, ie. normal sound via PulseAudio. Every instance
> > also uses a PVR to access TV and Radio from a dreambox.
> > 
> > How does it crash for you? Does it start at all, or does it suddenly
> > crash when you're e.g. playing some special video? When it is running,
> > you will find more details in ~/.kodi/temp/kodi.log
> Strange. Then it is probably somehow with me.
> The only difference is that you have Intel CPU and I have AMD. As well as 
> graphic nvidia.
> Could that be the reason?
> kodi starts, but kodi import the addons then comes: ....

This was obviously the first time Kodi 20 started which caused some
migration phase. I had different behaviour on all systems, especially
the one running on Winblows didn't want to talk to the PVR at all; it
even complained about the Enigma2 addon being incompatible! I tried it
the day after and, guess what, everything worked as before.

When such a major update is apparent, I usually save my whole ~/.kodi
directory elsewhere. When problems appear, I restart by copying the
content of the saved directory back to ~/.kodi

IIRC, such major updates always behaved different and need several
restarts of the application - on Winblows even a reboot of the system.

> Now I did this a few times in the console and now the error is gone?. Very 
> very strange.
> In the meantime I had uninstalled the zattoo addon from packman. After that, 
> the error still came at least once. 
> Now currently runs but kodi.
> I do not understand this. :-(

See above, I believe this could explain the behaviour you are seeing.

> Thanks for your answers though. Let's see if it stays like this.
> Regards
>  Eric


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: not available
URL: <http://lists.links2linux.de/pipermail/packman/attachments/20230203/9ea31eda/attachment.sig>

More information about the Packman mailing list