[packman] yt-dlp 2022.08.08 broken on 15.3
nomiya at galaxy.dti.ne.jp
Fri Aug 12 12:53:48 CEST 2022
In the Message;
Subject : Re: [packman] yt-dlp 2022.08.08 broken on 15.3
Message-ID : <2b730457880b50972dfd63f0189dfdb2edc72e76.camel at jsj.dyndns.org>
Date & Time: Fri, 12 Aug 2022 12:12:49 +0200
[SB] == Stefan Botter <jsj at jsj.dyndns.org> has written:
SB> On Fri, 2022-08-12 at 18:30 +0900, Masaru Nomiya wrote:
MN> > In the Changelog of yt-dlp, it is written as follows;
MN> > ### 2022.08.08
MN> > * **Remove Python 3.6 support**
MN> > So, I tried to build yt-dlp with python 3.8, the I could get yt-dlp rpm.
MN> > That is, the build requirement is python 3.8 or higher.
SB> Luigi made the successful submit request sr#994385 in OBS for the change
SB> to use python 3.9 for all versions older than Tumbleweed, in fact all
SB> distributions since 15.0 (he mentioned that earlier).
Ah, I see.
SB> We at PMBS build several packages linked to OBS sources, where there are
SB> some changes needed with respect to limitations, which OBS cannot
SB> provide, eg. legal causes or the like, we build the source with the
SB> respective modifications.
I have heard of OBS and PMBS, but have never looked into them.
I will look into it.
MN> > I can't understand why packman requires python 3.9 or higher.
MN> > Moreover,
MN> > 1. I think python 3.9 is the development version
MN> > and,
MN> > 2. The following repo has the stable version of python 3.10
MN> > https://download.opensuse.org/repositories/devel:/languages:/python/15.3/
MN> > ↑__ I have not checked if all modules are available here.
SB> Python 3.9 is available via the official update channel to at least 15.3
SB> and 15.4 as packages python39*.
SB> yt-dlp requires now at least python 3.8,
SB> so version 3.9 is the closest fit we can manage. Python 3.10 ist not
SB> (perhaps yet) available for Leap.
SB> We build packages in a way, that there are no outside dependencies for
SB> packages installed from packman. The term "outside" includes everything,
SB> which is not provided by PMBS itself, or the distribution repository and
SB> their respective update repositories. There is no possibility to build
SB> packages, which are not in these repositories.
SB> Your choice of python 3.10 resides in a different repository, which is
SB> not configured in a vanilla openSUSE Leap 15.x installation with added
SB> Packman repo. We have to stick with 3.9.
MN> > I don't know the merit of upgrading to python 3.10 for the sake of
MN> > yt-dlp, but in general, I think there is merit in doing so as more
MN> > and more applications are being developed in python.
SB> As someone mentioned earlier in this thread, you can have multiple
SB> versions of python installed, an this is handled using the alternative
SB> mechanism, so apart from a little additional disk space no harm is done,
SB> and you can use yt-dlp.
Yes, I know it.
I'm installing 3.8, 3.9, and 3.10 of python in my Tumbleweed.
3.8 and 3.9 are installed just to get python310-conan.
And, we can use yt-dlp without resorting to update-alternatives.
Thanks & Regards.
┏━━┓彡 Masaru Nomiya mail-to: nomiya @ galaxy.dti.ne.jp
┗━━┛ " Today’s China is not the old China humiliated and bullied over
100 years ago. It is time for these people to wake up from their
-- Hua Chunying’s Regular Press Conference on August 4, 2022 --
More information about the Packman