[packman] yt-dlp 2022.08.08 broken on 15.3

eric at schirra.net eric at schirra.net
Thu Aug 11 13:48:19 CEST 2022

Am 11.08.2022 um 13:25 schrieb Masaru Nomiya:
> You are mistaken.
> What yt-dlp needs is python3, not python.
> CER>  Thus, this package can not be published as is.
> CER>  I just tried to revert the update, but there are no older
> CER>  versions available. I have a local copy of 2022.07.18 and
> CER>  reverted to that one.
> python3 in Leap 15.3 is python3.6, right?
> yt-dlp requires python3.7 or higher.
> The solution in Leap 15.3 is installing python 3.8 (3.7 isn't
> availlable, is it?) and use update-laternatives.
Not so simple as it seems.

All python-modules in Leap are build against default dead python 3.6.

So you can not simple use 3.8 to build, because modules are not build 
against 3.8.



More information about the Packman mailing list