[packman] does packman have a new key or what is going on?

Stefan Seyfried stefan.seyfried at googlemail.com
Fri Oct 29 08:28:36 CEST 2021


On 29.10.21 01:21, S. wrote:
> On Thu Oct 28 11:40:34 CEST 2021 Marcel K├╝hlhorn wrote:
>> Interestingly, this only works with zypper, dnf and plain rpm fail to 
>> import the key
> 
> I'm running into the same issue trying to build an image with Kiwi and 
> manually importing the Packman key. I confirm that Zypper/YaST can 
> import the key, but not the underlying rpm tool. Strangely, this issue 
> actually appeared first when they updated the RPM version in Leap 15.3:
> https://lists.links2linux.de/pipermail/packman/2021-October/016849.html
> So Packman needs to somehow unset the "critical" bit from "Bit 7 of the 
> subpacket type", according to this:
> https://github.com/rpm-software-management/rpm/commit/f22499a05d0a01e35dd10d7644f8d74391ba4222 
> 
> That means nothing to me and it sounds difficult, but something needs to 
> be done to fix this.

probably rpm needs to be fixed to again accept keys that were totally 
fine before the update.

So I'd suggest filing a bug against 15.3 rpm package.

(I don't know much about key handling in RPM, so maybe the key is really 
broken and should not be used as-is, but then why is it acceptable to 
libzypp?)
-- 
Stefan Seyfried

"For a successful technology, reality must take precedence over
  public relations, for nature cannot be fooled." -- Richard Feynman



More information about the Packman mailing list