[packman] [PM] flash-player (openSUSE_Leap 15.1/x86_64)

Tony Mechelynck antoine.mechelynck at gmail.com
Thu Jan 23 18:45:13 CET 2020

On Thu Jan 23 15:53:12 CET 2020, Hans-Peter Jansen <hpj at urpla.net> wrote:

> Am Donnerstag, 23. Januar 2020, 14:50:34 CET schrieb Michael Schueller:
> > Hello
> >
> > I just noticed that the Flash player is not listed in the plugins of the
> > Firefox Browser (latest) and is not running.
> >
> > All three components are installed, what could be the reason ?
> Guess, you talk about Tumbleweed.
> Check this: https://lists.opensuse.org/opensuse-factory/2020-01/msg00056.html
> and this:
> https://build.opensuse.org/package/show/home:frispete:Tumbleweed/flash-player
> Cheers,
> Pete

Me, I'm not on Tumbleweed but on openSUSE Leap 15.1 just like the OP,
I'm not on Firefox but on SeaMonkey 2.53, I have enabled the Packman
repositories, and I see something similar but not identical:

In my about:addons (Add-Ons Manager) page, flash-player is mentioned, albeit with the following message
in red:
(-) Shockwave Flash is known to be vulnerable and should be updated
   _Update Now_

Also, the rolldown widget at right on the same line has lost the
"Always Activate" option, I can only choose between "Ask to Activate"
(the current setting) or "Never Activate". This means that any site
which tests if Flash is installed will get a "no" answer and tell me
"Please install Flash" instead of trying to use it and producing the
browser-generated question "Do you want to enable Flash for
www.example.com ? [ Enable ] [ Cancel ]" or something like that.

I haven't tried clicking the "Update Now" button, because when I did
so for earlier Flash versions in the past, I was sent to some Adobe
page where a Flash NPAPI plugin could be downloaded, but not one
compatible with the "flash-player", "flash-player-gnome" and/or
"flash-player-ppapi" packages found on the Packman repositories.

The "Software Management" function of YaST tells me that on all the
repositories I have enabled, the only available version of the Flash
packages is, and only from Vendor

When I had a similar message a few weeks ago about an earlier version
of the same plugin, I asked about it in IRC (#packman on
irc.freenode.net) and I got the answer: "I updated the package, but
nobody cares about Flash anymore, you'll get the same error again when
this new version gets outdated" with a link to this mailing list.

So, long story short: Please, someone, push an updated version of the
three above-mentioned Flash packages to the Packman repository for
openSUSE Leap 15.1.

Best regards,

More information about the Packman mailing list