[packman] Packaging request - VidCutter

Carlos E. R. robin.listas at telefonica.net
Wed Feb 15 23:48:00 CET 2017


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Content-ID: <alpine.LSU.2.20.1702152339550.5294 at zvanf-gvevgu.inyvabe>


El 2017-02-15 a las 16:49 -0000, Gerhard K├╝hbauer escribi├│:
> Am 2017-02-14 um 23:49 schrieb Carlos E. R.:
>
>>  From one of those I took a clip:
>>
>>   dd if=Cine.mpeg of=clip.mpeg2 bs=1M count=5
>>
>> being at the start of the movie, it is just the commercials. I'll mail
>> that in an instant.
>>
>> Here goes.
>>
>> And thanks, see if you can find out something.

> MPEG4-AVC in an MPEG-TS-container... Interesting! There is no problem
> with the video itself. Every decent videoplayer plays it fine without
> any problems, although at first it wasn't even recognized as a
> videofile. My first try of editing it was with Avidemux and there were
> no problems doing that. When I tried to do the same with Vidcutter the
> following happened: http://i.imgur.com/rwekRuK.png

Yes, that is the problem I was trying to describe.


> Very strange & definitely unusable! I don't know what exactly is causing
> this weird behaviour of Vidcutter, but it seems to have something to do
> with the quite unusual combination of videocodec/format/container.
> Fortunately there is a very easy solution to fix this problem - simply
> put your videos in an another "container". In my humble opinion mkv
> (Matroska) would be a good choice . This can be done with:
>
> - ffmpeg -i clip.mpeg2 -vcodec copy -acodec copy clip.mkv or
> - mkvmerge -i clip.mpeg2 -o clip.mpeg2.mkv
>
> Mkvmerge is part of mkvtoolnix and also available with a gui.
> The difference: http://i.imgur.com/tkpOd4w.png
>
> Strangely exactly the same video, just in another container, can be
> opened and edited by Vidcutter without any problems.

Without recoding? You use the "copy" codec. Curious!

> The quality of the
> video stays exactly the same and process is very fast. Yes, that's
> another workaround regarding Vidcutter for you, but at least it gives
> you the possibility to edit your videos with a working preview. It is
> planned that the next major release of Vidcutter will be using libmpv
> instead of the QMediaPlayer/GStreamer and maybe that will solve your
> issue. Nonetheless I think you should let the developer know of this
> particular problem - just to make sure the issue will be hopefully &
> definitely solved in the next releases...

Sure, I'll do.

Those files also have a sync problem, but I have an ffmpeg command that 
corrects it. Let's see if I can find it... It would be another way to 
process with vidcutter, use the already processed stream.

I think I used this:

ffmpeg -i "input.mpeg" -copyts -map 0:0 -map 0:1 -map 0:2  -c:v libx264 -preset ultrafast -vf crop=1920:804:0:138 -c:a copy "output.mkv"

I will try that on this movie and comment back. Without the crop filter, 
not needed.

I will also try your method, it will process much faster.

Thanks!

- -- 
Cheers
        Carlos E. R.

        (from 42.2 x86_64 "Malachite" (Minas Tirith))
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iF4EAREIAAYFAlik2qgACgkQja8UbcUWM1xx0AD/T6J9a6cP2LiI3Tm1KmzzQRNG
az9Be3erYvPQiFlzZC8BAJnGgSjJB/k3l6vyq80vdp8qKvkIjC4YldUeKK3JbLI0
=I0DZ
-----END PGP SIGNATURE-----


More information about the Packman mailing list