[packman] Packaging request - VidCutter

Gerhard K├╝hbauer vienna550 at hotmail.com
Wed Feb 15 17:49:57 CET 2017


Am 2017-02-15 um 10:38 schrieb Olaf Hering:
> Am Tue, 14 Feb 2017 21:22:28 +0100
> schrieb "Luigi Baldoni" <aloisio at gmx.com>:
>
>> Will see what I can do, I've also discovered it was already
>> in multimedia:apps, will try and unify them.
> Should the package be provided by packman, or is the copy in OBS enough?
>
> Olaf

I apologize for causing you additional and it seems even unnecessary 
workload. That wasn't my intention and I'm sorry...


Am 2017-02-14 um 23:49 schrieb Carlos E. R.:

>  From one of those I took a clip:
>
>   dd if=Cine.mpeg of=clip.mpeg2 bs=1M count=5
>
> being at the start of the movie, it is just the commercials. I'll mail
> that in an instant.
>
> Here goes.
>
> And thanks, see if you can find out something.
MPEG4-AVC in an MPEG-TS-container... Interesting! There is no problem 
with the video itself. Every decent videoplayer plays it fine without 
any problems, although at first it wasn't even recognized as a 
videofile. My first try of editing it was with Avidemux and there were 
no problems doing that. When I tried to do the same with Vidcutter the 
following happened: http://i.imgur.com/rwekRuK.png

Very strange & definitely unusable! I don't know what exactly is causing 
this weird behaviour of Vidcutter, but it seems to have something to do 
with the quite unusual combination of videocodec/format/container. 
Fortunately there is a very easy solution to fix this problem - simply 
put your videos in an another "container". In my humble opinion mkv 
(Matroska) would be a good choice . This can be done with:

- ffmpeg -i clip.mpeg2 -vcodec copy -acodec copy clip.mkv or
- mkvmerge -i clip.mpeg2 -o clip.mpeg2.mkv

Mkvmerge is part of mkvtoolnix and also available with a gui.
The difference: http://i.imgur.com/tkpOd4w.png

Strangely exactly the same video, just in another container, can be 
opened and edited by Vidcutter without any problems. The quality of the 
video stays exactly the same and process is very fast. Yes, that's 
another workaround regarding Vidcutter for you, but at least it gives 
you the possibility to edit your videos with a working preview. It is 
planned that the next major release of Vidcutter will be using libmpv 
instead of the QMediaPlayer/GStreamer and maybe that will solve your 
issue. Nonetheless I think you should let the developer know of this 
particular problem - just to make sure the issue will be hopefully & 
definitely solved in the next releases...






More information about the Packman mailing list