[packman] [PM] devede 3.22.0-2.26 (openSUSE 13.1/noarch)

Wolfgang Bauer e9325712 at student.tuwien.ac.at
Fri May 2 14:20:19 CEST 2014

Am Freitag, 2. Mai 2014, 13:54:08 schrieb Wolfgang Bauer:
> Am Freitag, 2. Mai 2014, 04:55:35 schrieb Carl Fletcher:
> > Thanks - Yes. I figured that out.
> > But now the application crashed out on selecting the destination dir.
> > I managed to get it to select and start once but then the process never
> > actually moved on from 0%
> > 
> > FYI: I tried on the same machine with Kubuntu 14.04 and had the same
> > application behavior issues
> > Currently Mint 13 Mate on my Netbook is processing what I need with devede
> AFAIK devede has problems with KDE's gtk2-oxygen theme.
> Try to change the GTK2 theme to something else and it should not crash.

PS: I tried it myself again now (I don't use devede), and while it doesn't 
crash with a different theme, unfortunately it doesn't work either, I see what 
you describe. (the process never actually moved on from 0%)

Following output appears in the terminal:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/devede_main.py", line 475, in 
    if conversor.create_disc():
  File "/usr/lib/python2.7/site-packages/devede_convert.py", line 365, in 
  File "/usr/lib64/python2.7/posixpath.py", line 77, in join
    elif path == '' or path.endswith('/'):
AttributeError: 'NoneType' object has no attribute 'endswith'

Should be fixed with this upstream commit:

With this patch it works fine here.
So I guess it's time for yet another bug report... ;-)

Btw, you can apply the fix yourself. Just open the file /usr/lib/python2.7/site-
packages/devede_convert.py in a text editor (as root) and add the following 
after line 353, which should read "filefolder=wdir.get_current_folder()":
                if filefolder is None:

Kind regards,

More information about the Packman mailing list