[packman] No Miro package anymore?

Karl Ove Hufthammer karl at huftis.org
Fri Mar 22 17:11:32 CET 2013

fr. den 22. 03. 2013 klokka 11.50 (+0100) skreiv Stefan Botter:
> > I have now installed the package, but launching it doesn’t work. I
> > get the same error message as when I try to run the application from
> > source, so it looks like the problem is that libwebkit(gtk) is
> > configured to use gstreamer-1.0 instead of gstreamer-0.10, and this
> > causes conflicts. libwebkit by default actually uses gstreamer-0.10,
> > but the openSUSE packages are configured to use gstreamer-1.0.
> miro is now at  5.0.4 and compiles against gstreamer 1.0.
> Please try, I do not use it, so I canot test.

Thanks for trying to fix this!

It still doesn’t work, though (same error as before – stalling when
launching). The reason is probably that Miro only support gstreamer
0.10, so compiling it against 1.0 won’t work. Support for the 
gstreamer 1.0 API requires a somewhat major rewrite:

I have tried compiling libwebkit and libwebkit3 against 
gstreamer 0.10. The result is available in this repository:

With this, your Miro package almost works, i.e., the launch process
reaches a later stage, and successfully manages to update the Miro
database, but ultimately it crashes with a segfault before the
GUI is started.

But compiling Miro from source, everything seems to work
fine (with the modified libwebkit libraries).

BTW, regarding the libxine requirements: I believe Miro doesn’t 
use xine anymore, so you can remove the package requirements.

Karl Ove Hufthammer
Jabber: karl at huftis.org

More information about the Packman mailing list