[packman] SOLVED (Re: [PM] mythtv-0_27 0.27-1.6 (openSUSE 12.3/x86_64))

Herbert Graeber herbert at graeber-clan.de
Fri Dec 20 18:26:23 CET 2013


Am Donnerstag, 19. Dezember 2013, 06:55:29 schrieb Hubert Mantel:
> On Thu, Dec 19, Hubert Mantel wrote:
> > I'm just in the middle of setting up myththv when I got this update.
> > Unfortunately it is broken:
> > 
> > mythfrontend: symbol lookup error: /usr/lib64/libmythavcodec.so.54:
> > undefined symbol: vpx_codec_vp9_dx_algo
> > 
> > lrwxrwxrwx 1 root root      27 Dec 19 06:19 libmythavcodec.so.54 ->
> > libmythavcodec.so.54.92.100* -rwxr-xr-x 1 root root 8264616 Dec 18 06:18
> > libmythavcodec.so.54.92.100*
> Problem solved by updating to libvpx1-1.3.0-7.1.x86_64.rpm
> Dependencies seem to be missing.

Hmm. I think the right libraries should be required automatically.

But that's not the case, when a package switches from one repository to another. 
libvpx1-1.2 came from openSUSE, libvpx1-1.3 from packman. The only case to solve 
this would be to explicitly require 1.3. Maybe I have to do that for other libraries that 
have been overridden by packman, too.

I am preparing new packages with the latest fixes.

"Any sufficiently advanced technology is indistinguishable from magic."
/Arthur C. Clarke/

More information about the Packman mailing list