[packman] pmbs: libffmpeg-devel fails to find its dependencies

Manfred Tremmel manfred at links2linux.de
Wed Oct 3 19:58:32 CEST 2012


Am Mittwoch, 3. Oktober 2012, 13:58:27 schrieb J├╝rgen Weigert:
> Hey Packmen!
> 
> I am re-building home:jnweiger/dvswitch and home:jnweiger/dvswitch-git
> and see the foolowing issues with its dependencies:
> 
> openSUSE_12.1        i586       succeeded
> openSUSE_12.1        x86_64     succeeded
> openSUSE_12.2        i586       unresolvable: nothing provides
> libavutil51 = 1.0 needed by libffmpeg-devel
>       nothing provides libavutil51 = 1.0 needed by libavcodec54
>       nothing provides libavutil51 = 1.0 needed by libswresample0
>       nothing provides libavutil51 = 1.0 needed by libswscale2
>       nothing provides libavutil51 = 1.0 needed by libavformat54
>       nothing provides libavutil51 = 1.0 needed by libavdevice54
>       nothing provides libavutil51 = 1.0 needed by libavfilter3
>       nothing provides libavutil51 = 1.0 needed by libpostproc52
>       have choice for libidn.so.11 needed by libcurl4: libidn libidn11
> have choice for libidn.so.11(LIBIDN_1.0) needed by libcurl4: libidn
> libidn11
> 
> I guess I can add Prefer: libidn11 to my prjconf to help with the

Yes, you have to do this.

> 'have choice' issue; but I am not sure what to do about the 'nothing
> provides libavutil51 = 1.0' thing. Any ideas?

The libavutil51 rpm is a subpackage of ffmpeg and it's available on the 
server. Do you have changed anything, the package looks ok, now.

-- 
Machs gut    | http://www.iivs.de/schwinde/buerger/tremmel/

Manfred      | http://packman.links2linux.de/




More information about the Packman mailing list