[packman] Manual dependencies on ffmpeg: not good
manfred at links2linux.de
Sun Jun 17 14:39:09 CEST 2012
Am Dienstag, 12. Juni 2012, 18:01:39 schrieb Jan Engelhardt:
> My openSUSE_12.1 system currently has ffmpeg-0.9.1-1.1[packman], but
ffmpeg 0.9.1 has been replaced in January, you realy should update to
the latest version.
> zypper does not want to update to ffmpeg-0.11[packman], because of
> some whacky manual dependencies that someone had added. Drilled down
> (minimal testcase), in rpm lingo,:
make a "zypper dup", this should resolve.
> # rpm -Uhv libavcodec54-0.11-4.1.x86_64.rpm error: Failed
> dependencies: libavutil51 = 0.11 is needed by
> libavcodec54-0.11-4.1.x86_64 # rpm -Uhv
> libavcodec54-0.11-4.1.x86_64.rpm libavutil51-0.11-4.1.x86_64.rpm
> error: Failed dependencies:
> libavutil51 = 0.9.1-1.1 is needed by (installed)
Non of our packages should depend on libavdevice53 anymore.
> Installation of libavcodec54 would force libavdevice53 out the
> system, which is an operation that is penalized by zypper and thus
> not rejected for "zypper up". libavdevice53.rpm is set to depend on a
> specific libavutil51 version. That is not how library versioning is
> meant to be done.
This is how to prevent from incompatiblities through out different
compiling options or other problems.
> 1. If avdevice53 really requires avutil51-0.9.1 (rather than any
> avutil.so.51), the ffmpeg folks screwed up their ABI.
> 2. If the dependency is artificial, remove the manual deps and let
> Automatic Dependency resolution do its job.
I can not test all possible problematic constellations, it's no option.
Tell me which packages still requires libavdevice53 and i try to fix it.
And when evern BuildServer works again it will be build. Keeping old
unsecure libraries in system is no option.
Machs gut | http://www.iivs.de/schwinde/buerger/tremmel/
Manfred | http://packman.links2linux.de/
More information about the Packman