[packman] vlc: no h264/x264 decoder [SOLVED]

Dominik Kopp my at kabelfunk.de
Sat Jul 7 11:38:56 CEST 2012

Manfred Tremmel wrote:

> Am Dienstag, 3. Juli 2012, 22:02:39 schrieb Dominik Kopp:
>> Manfred Tremmel wrote:
>> > Am Sonntag, 1. Juli 2012, 17:55:13 schrieb Masaru Nomiya:
>> ...
>> > So more interesting is what's the version of libavcodec (rpm -q
>> > libavcodec54).
>> > I'm using ffmpeg to watch HD-TV which uses H.264, I don't have any
>> > problems, so it shouldn't be a generel problem.
>> dom at alone:~> rpm -q libavcodec54
>> libavcodec54-0.11.1-1.1.x86_64
>> and no, I can't reproduce it in a VirtualBox installation. :-(((
>> Any idea, what could be wrong?
> It's not easy to say, maybe a mix of Videolan and Packman Packages?

with vlc -vv I've got a more detailed error messages:

[0x7f74d8e3ed08] main decoder warning: cannot load module 
`/usr/lib64/vlc/plugins/codec/libavcodec_plugin.so' (/usr/lib64/libva-
x11.so.1: undefined symbol: _XGetRequest)                                                                                                                               
[0x7f74d8e3ed08] main decoder error: corrupt module: 
[0x7f74d8e3ed08] main decoder debug: no decoder module matching "any" could 
be loaded
[0x7f74d8e3ed08] main decoder debug: TIMER module_need() : 45.433 ms - Total 
45.433 ms / 1 intvls (Avg 45.433 ms)
[0x7f74d8e3ed08] main decoder error: no suitable decoder module for fourcc 
`h264'. VLC probably does not support this sound or video format.

I had used a libva package from X11 repo. (version 1.1.0)
So I switched back to the default version of 1.0.14 (suse 12.1)
and vlc works now!

More information about the Packman mailing list