[packman] [PM] aMule 2.3.1-1.4 (openSUSE 12.1/src)

Осипов Женя zenitur at yandex.ru
Thu Aug 2 11:03:38 CEST 2012


I found a mistake in SRPM of aMule when tried to build it in openSUSE 11.4. Before build I install wxWidgets from Factory because of aMule 2.3.1 needs wxWidgets 2.8.12, not less. openSUSE 11.4 has wxWidgets 2.8.11.

1). BuildRequires:  wxWidgets-wxcontainer-devel. In http://en.opensuse.org/openSUSE:Packaging_wxWidgets I read that wxcontainer is deprecated, and all applications need be compiled with stl (wxWidgets-devel). I don't know, is it possible to run application build with deprecated wxcontainer with not deprecated stl, but I think, no.

A possible ways to fix:


-BuildRequires:  wxWidgets-wxcontainer-devel
+BuildRequires:  wxWidgets-devel


%if %{version} < 2.3.1
BuildRequires:  wxWidgets-wxcontainer-devel
BuildRequires:  wxWidgets-devel

2). "%if %suse_version <= 1130" in spec file. But openSUSE 11.3 has an old version of wxWidgets. Is it time to remove the outdated condition, which is probably used to compile aMule 2.2.6? Or if not, change the condition to compile in openSUSE 11.3, add a condition for 11.4, which makes checking for wxWingets 2.8.12 and later.

3). Forgotten RPM-macros debug_info which leads to 248.5 Mb of builded RPM.


More information about the Packman mailing list