[packman] [PM] Miro 3.5.1-1.pm.1.9 (openSUSE 11.3/x86_64)

Daniel Lee lee.daniel.1986 at googlemail.com
Thu Dec 23 23:38:49 CET 2010

Dear Mr. Reichelt,

I've tried a few times - always unsuccessfully - to get Miro running on my
computer with OpenSUSE 11.3 64-bit KDE. Whether installing Miro from the
Packman repository with the Software Manager or using the 1 click install
provided on the package's site, it doesn't start if I attempt to call it up
from my Kicker menu. If I use the terminal I get the following output:

PyNotify support disabled on your platform.
2010-12-23 23:34:30,660 INFO     Starting up Miro
2010-12-23 23:34:30,661 INFO     Version:    3.5.1
2010-12-23 23:34:30,661 INFO     Revision:   ssh://
ben at git.participatoryculture.org:2191/var/git/miro - e5e3cabb
2010-12-23 23:34:30,661 INFO     Builder:    abuild at eckhaus
2010-12-23 23:34:30,661 INFO     Build Time: 1293043007.88
2010-12-23 23:34:30,661 INFO     Reading HTTP Password list
2010-12-23 23:34:30,662 INFO     Starting libCURL thread
2010-12-23 23:34:30,663 INFO     Starting event loop thread
2010-12-23 23:34:30,663 INFO     Restoring database...
2010-12-23 23:34:30,666 INFO     Sqlite3 version:   3.6.23
2010-12-23 23:34:30,666 INFO     Pysqlite version:  2.4.1
2010-12-23 23:34:30,666 INFO     opening database /home/Lee/.miro/sqlitedb
2010-12-23 23:34:30,673 ERROR    error when upgrading database: no such
table: dtv_variables
Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 233,
in upgrade_database
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 322,
in _upgrade_database
    self.startup_version = current_version = self._get_version()
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 839,
in _get_version
    return self._get_variable(VERSION_KEY)
  File "/usr/lib64/python2.6/site-packages/miro/storedatabase.py", line 373,
in _get_variable
    "WHERE name=?", (name,))
OperationalError: no such table: dtv_variables
2010-12-23 23:34:30,674 INFO     Linux version:     Linux x86_64
2010-12-23 23:34:30,674 INFO     Python version:    2.6.5 (r265:79063, Oct
28 2010, 20:56:23)
[GCC 4.5.0 20100604 [gcc-4_5-branch revision 160292]]
2010-12-23 23:34:30,675 INFO     Gtk+ version:      (2, 20, 1)
2010-12-23 23:34:30,675 WARNING  upgrade failed. Backing up database to
2010-12-23 23:34:30,675 INFO     PyGObject version: (2, 21, 1)
2010-12-23 23:34:30,676 INFO     PyGtk version:     (2, 17, 0)
2010-12-23 23:34:30,676 INFO     Language:          [('LANG',
2010-12-23 23:34:30,695 INFO     libtorrent:
2010-12-23 23:34:30,696 INFO     pycurl:            libcurl/7.20.1
OpenSSL/1.0.0 zlib/1.2.3 libidn/1.15 libssh2/1.2.2_DEV
2010-12-23 23:34:30,696 INFO     set_renderer: trying to add
/usr/bin/python: symbol lookup error:
/usr/lib64/python2.6/site-packages/gst-0.10/gst/_gst.so: undefined symbol:

After attempting to find answers in every forum I could find, it seems that
it's a general problem with the package.

I also tried at work to compile Miro from source on a freshly installed
computer with the same system (OpenSUSE 11.3 64-bit KDE), but also failed -
although I was able to find the cause of many of the problems and install
missing dependencies, I was unable to resolve all of the issues and, in the
end, unable to get Miro to install. It claimed to have a problem with Gconf
(sadly, I don't have the output here, but it's probably not relevant for you
anyway since you put together the package and not the software itself ;) ).

Since this seems to be a general problem, do you have any suggestions as to
what I could do to fix it? Or are there plans to publish a Miro package that
actually works with OpenSUSE? I'd be really grateful for an answer. Thanks a
lot and merry Christmas!

Daniel Lee

More information about the Packman mailing list