[packman] [PM] broadcom-wl (openSUSE 11.1/i586)

Andrea Florio andrea at links2linux.de
Sun Mar 15 00:59:54 CET 2009

Hash: SHA1

Brian Masinick ha scritto:
> I have openSUSE 11.1 installed on a Gateway PA6A 17" laptop, really more of a 
> mobile desktop.  This particularly hardware has been very Linux friendly, and 
> including openSUSE, I have eight distinct Linux instances.  Except for openSUSE, 
> all of them are presently working with the Broadcom 4311 network card that is 
> installed.
> Though I was surprised that it apparently wasn't there, I went out and 
> explicitly installed the Broadcom firmware for this device.  That has not been 
> the end of my issues.  The standard "network manager" doesn't want to start up, 
> even when I use knetworkmanager.  I figured, "Fine, I'm not that keen on 
> networkmanager anyway, I will just go out and get wicd, which always works".  
> That has not been an easy exercise either.  I tried several incantations, and 
> finally grabbed the source, built it and installed it because the packages in 
> various repositories just did not want to cooperate.  To the best of my 
> knowledge, I have wicd 1.5.9 now installed.  I say, "To the best of my 
> knowledge" because these components are clearly not working together as they 
> should.  What is so perplexing is that I have previously had scans correctly 
> scan the wireless network in my area, and the scans are seeing what's out there 
> correctly, including my equipment and the neighbors around me.  I see it all 
> fine, and I've had the software SAY that it is connected, but the network just 
> won't work.  If I turn around and enable the wired network, everything is fine.
> Therefore I conclude that something is still not quite right, but I have no idea 
> what to look for to correct it further.  Yet if I simply reboot to another Linux 
> instance, as I have now, the wireless hardware most certainly is working correctly.
> My expertise with SUSE based tools is limited.  I could use some assistance if 
> you are willing and able.
> Would you recommend removing any software and starting over, or what steps would 
> you take?  What additional information would be helpful to perform some 
> diagnostic action?
> lspci
> 00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT 
> Express Memory Controller Hub (rev 03)
> 00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 
> 943/940GML Express Integrated Graphics Controller (rev 03)
> 00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML 
> Express Integrated Graphics Controller (rev 03)
> 00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition 
> Audio Controller (rev 02)
> 00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 
> (rev 02)
> 00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 
> (rev 02)
> 00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
> Controller #1 (rev 02)
> 00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
> Controller #2 (rev 02)
> 00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
> Controller #3 (rev 02)
> 00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI 
> Controller #4 (rev 02)
> 00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI 
> Controller (rev 02)
> 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
> 00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge 
> (rev 02)
> 00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller 
> (rev 02)
> 00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI 
> Controller (rev 02)
> 00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
> *03:00.0 Network controller: Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01)*
> 04:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection 
> (rev 02)
> 04:09.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
> 04:09.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 
> Host Controller
> 04:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader 
> Thank you for any suggestions you may be able to offer.
> Sincerely yours,
> Brian Masinick

your card is perfectly supported by broadcom poprietary drivers, but
because of legal stuffs (kernel is GPL, broadcom wl use kernel headers,
but include a proprietary blog) novell decide to avoid any legal
problem. both, Network Manager and yast works fine with that driver. i
never used wicd)

all informations you need can be found here:

Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org


More information about the Packman mailing list