[packman] broken packages: opal/pwlib

Jan Engelhardt jengelh at linux01.gwdg.de
Sat Mar 10 01:28:13 CET 2007


Hallo,


In opal.spec(packman) befindet sich folgende wirre Obsoletes-Zeile...

	Obsoletes:      opal = 2.3.1

das f├╝hrt nun dazu, dass smart hin und her alteriert, wenn man es 
wiederholt mit `smart upgrade` aufruft.


	ccd# smart upgrade
	Loading cache...
	Updating cache...               ######################################## [100%]
	
	Channels have no new packages.
	Computing transaction...
	
	Upgrading packages (2):
	  opal-2.3.1-30 at i586        pwlib-1.11.1-27 at i586      
	
	Downgrading packages (2):
	  opal-2.3.1-30 at i586        pwlib-1.11.1-27 at i586      
	
	4.0MB of package files are needed. 2.2MB will be used.
	
	Confirm changes? (Y/n): 
	
	                                                                               
	Fetching packages...
	-> ftp://ftp5.gwdg.de/pub/opensuse/distribution/.../pwlib-1.11.1-27.i586.rpm   
	-> ftp://ftp5.gwdg.de/pub/opensuse/distribution/10.2/.../opal-2.3.1-30.i586.rpm
	pwlib-1.11.1-27.i586.rpm        ######################################## [ 50%]
	opal-2.3.1-30.i586.rpm          ######################################## [100%]
	
	                                                                               
	Committing transaction...
	Preparing...                    ######################################## [  0%]
	   1:Installing pwlib           ######################################## [ 25%]
	   2:Cleaning pwlib             ######################################## [ 50%]
	   3:Installing opal            ######################################## [ 75%]
	   4:Cleaning opal              ######################################## [100%]
	
	Saving cache...
	
	ccd# smart upgrade
	Loading cache...
	Updating cache...               ######################################## [100%]
	
	Computing transaction...
	
	Upgrading packages (2):
	  opal-2.2.5-1.pm.1 at i586    pwlib-1.10.4-1.pm.3 at i586  
	
	Downgrading packages (2):
	  opal-2.2.5-1.pm.1 at i586    pwlib-1.10.4-1.pm.3 at i586  
	
	3.4MB of package files are needed. 2.2MB will be freed.
	
	Confirm changes? (Y/n): 
	
	Fetching packages...                                                           
	-> ftp://ftp5.gwdg.de/pub/linux/misc/packman/.../pwlib-1.10.4-1.pm.3.i586.rpm  
	-> ftp://ftp5.gwdg.de/pub/linux/misc/packman/.../opal-2.2.5-1.pm.1.i586.rpm    
	pwlib-1.10.4-1.pm.3.i586.rpm    ######################################## [ 50%]
	opal-2.2.5-1.pm.1.i586.rpm      ######################################## [100%]
	
	                                                                               
	Committing transaction...
	Preparing...                    ######################################## [  0%]
	   1:Installing pwlib           ######################################## [ 25%]
	   2:Cleaning pwlib             ######################################## [ 50%]
	   3:Installing opal            ######################################## [ 75%]
	   4:Cleaning opal              ######################################## [100%]
	
	Saving cache...
	
	# smart upgrade
	Loading cache...
	Updating cache...               ######################################## [100%]
	
	Computing transaction...
	
	Upgrading packages (2):
	  opal-2.3.1-30 at i586        pwlib-1.11.1-27 at i586      
	
	Downgrading packages (2):
	  opal-2.3.1-30 at i586        pwlib-1.11.1-27 at i586      
	
	4.0MB of package files are needed. 2.2MB will be used.
	
	Confirm changes? (Y/n): 





Jan
-- 




More information about the Packman mailing list