[packman] Re: [PM] tovid 0.31 (openSUSE 10.3/i586)

Toni toni at links2linux.de
Tue Dec 25 13:13:57 CET 2007

Am Dienstag, 25. Dezember 2007 schrieb MurdocK:
> Hi Toni,
> First of all, thanks for your work for openSUSE.
> I have a problem with tovid with simple menĂ¹, I get this error:
> jamiro at suse32:~> tovidgui -s
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Running command:
> makemenugui
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> tovidgui requires wxPython 2.6 or 2.8.
> Please install or upgrade wxPython.
> But wxPython 2.8 are installed... it's a path problem?
no, this is a bug already reported to the tovid-Authors, and they fixed it.
and a new package was builded.

in the source code makemenugui.py you find:
# Use wx version 2.6 or 2.8
_allowed_versions = [
except wxversion.VersionError:
    print "tovidgui requires wxPython 2.6 or 2.8."
    print "Please install or upgrade wxPython."

so your python module does not match those criterias.

Which version of wxPython do you use ?
==> rpm -q wxPython

> Thanks for your help.
> Bye
> MurdocK
have fun

More information about the Packman mailing list